وردپرس 2.3 و مشکلات

عرضم به حضور شما دیروز بعد از ارتقاء وردپرس به نسخه 2.3 استاد شیدا متوجه مشکلاتی در هنگام نظر دادن شد! چندین Error از Database زد بیرون که بسی خاطر ما را تلخ نمود. بعد پیگری در انجمن های wordpress.org دیدم که ظاهرا این مشکل گریبان خیلی ها رو مثل من گرفته. در همین مبحث به لینکی برخوردم که تغییراتی که وردپرس 2.3 در Database ایجاد میکرد رو نام برده بود. گویا 3 تا از Table ها به نام های: categories, post2cat و link2cat در Database بعد از ارتقاء به نسخه 2.3 تغییر میکنه و همین باعث این مشکلات میشه.
خلاصه امروز تصمیم گرفتم به نسخه 2.2.3 برگردم و دوباره این عملیات ارتقاء رو یک بار دیگه انجام بدم. بعد از اینکه دوباره این عملیات رو انجام دادم وقتی همه افزونه ها غیر فعال بود دیدم هیچ پیغام خطایی در هیچ کدوم از قسمت ها وجود نداره! فهمیدم که مشکل به یکی از افزونه ها برمیگرده، پس شروع کردم دونه دونه افزونه ها رو فعال کردم دیدم بله Error رو نسخه قدیمی افزونه Google Sitemap ایجاد میکنه. بعد از ارتقاء افزونه به نسخه 3 دیدم باز هم یه سری Warning موقع نظر دادن پیدا میشه که مربوط به افزونه Popularity Contest هست، این افزونه هم پاک کردم چون هنوز نسخه جدیدی ازش نیومده.
در حال حاظر هیچ Error دیگه ای تو وبلاگ من وجود نداره و بقیه افزونه هام بدون مشکل داره کار میکنه
یک بار دیگه هم یادآوری میکنم حتما حتما قبل از ارتقاء به 2.3 همه افزونه ها رو غیر فعال کنید.

یه نکته هم در مورد تگ ها بگم اینکه برای انتقال تگ ها از Ultimate Tag Warriro به وردپرس 2.3 یک ایمپورتر در dashboard > Manage > Import قرار داده شده که این کارو انجام میده

فعلا

13 فکر می‌کنند “وردپرس 2.3 و مشکلات

  1. محمود

    راستی یک سئوال
    من مدت زیادی هست که از پلاگین poularity contest استفاده میکنم . مشکل بزرگی که دارم اینه که توی پوسته i3theme نمیتونم کد فعال شدن نمایش برای دیگران که بصورت در widget قرار بدهم . در واقع وقتی در یک widget text میزنم هیج چیزی نشون نمیده !!
    حالا سئوال کلی ام اینه که widget قابلیت اجرای توابع php را نداره ؟ و برای حل مشکل باید چیکار کرد ؟

    پاسخ
  2. Mizsia

    شرمنده ، الان دیدم تعدادی رو به روز کرده تعدادی رو نه… این افزونه هم جزء به روز نشده هاست…
    من فکر کردم همه رو به روز کرده…

    پاسخ
  3. حرف زیادی

    از تبریکتون ممنون.منم به شما تبریک میگم به خاطر گواهی نامه..ایشالا ماشینم به زودی:)

    پاسخ
  4. به فرنگ برگشته

    سئوال:
    من سئوالات ورد پرسم رو باید کجا و از کی بپرسم.
    چگونه میتوانم از اسکریپت بلاگرولینگ پوسته بلاگ اسپاتم در پوسته جدیدم در وردپرس استفاده کنم؟
    آیا این امکانات فارسی ورد پرس برای وبلاگ من هم که در دامنه مجانی ورد پرس است نیز قابل استفاده است؟

    پاسخ
  5. hassan

    من تا چند روز پیش نسخه 3.4 رو داشتم استفاده میکردم که خوبم کار میکرد. بعد update خواست و منم به نسخه 3.6 ارتقا دادم.
    حالا مشکلی که هست افزونه Estro Slider من رو صفحه شو سیاه کرده.
    میخوام بدونم الان باید چی کار کنم. چجوری برگردم به نسخه 3.4 ؟
    اصلان امکانش هست؟
    یا مشکلم راه حلی داره؟
    ممنون میشم کمکم کنید.
    با تشکر.

    پاسخ
    1. مهرداد نویسنده

      اینکه افزونه خاصی در ورژن فعلی که نصب دارید کار نکنه به احتمال خیلی زیاد به دلیل هماهنگ نبودن اون افزونه با نسخه وردپرس شماست
      برای برگشتن به نسخه‌های پایین‌تر نیاز هست که تمام فایل‌های وردپرس غیر از فایل wp-config.php رو پاک کنید و فایل‌های وردپرس نسخه پایینتر رو جایگزین کنید
      برای راهنمایی بیشتر تو لینک‌های زیر توضیحاتی اومده:
      http://etuts.org/manually-downgrade-wordpress/
      http://stackoverflow.com/questions/13854374/downgrading-wordpress-to-previous-version

      پاسخ

پاسخ دهید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *